How do I configure Brocade ServerIrons to load balance traffic over multiple PacketShapers?

Solution

Overview

 This configuration example shows a pair of ServerIron 450’s configured to load balance traffic over three

PacketShapers.  Traffic between clients on the left and the Server on the right is balanced over the three

PacketShapers with flows between src-dst address pairs always traversing the same PacketShaper.  This allows

the PacketShapers to correctly classify and shape traffic.  Failover was tested by disconnecting the cable between

a ServerIron and one of the PacketShapers.  Traffic is seamlessly redistributed over the remaining two PacketShapers.

 

 

 

 

 

ServerIron configurations

 

The ServerIron 450’s are running Version 10.2.01mTD4.

 

ServerIron-1

 

!Current configuration : 1515 bytes

!

ver 10.2.01mTD4

!

module 1 bi-0-port-wsm6-management-module

module 2 bi-jc-16-port-gig-copper-module

module 3 bi-jc-16-port-gig-copper-module

!

global-protocol-vlan

!

trunk switch ethe 2/1 to 2/4

!

server fw-port 2/1

!

!

server force-cache-rehash

!

context default

!

server fw-name 02/01PS1 192.168.13.3

!

server fw-name 02/02PS2 192.168.13.4

!

server fw-name 02/03PS3 192.168.13.5

!

server fw-group 2

 l2-fwall

 fw-name 02/01PS1

 fw-name 02/02PS2

 fw-name 02/03PS3

 

 fwall-info 1 2/1 192.168.13.1 192.168.13.1

 fwall-info 2 2/2 192.168.13.1 192.168.13.1

 fwall-info 3 2/3 192.168.13.1 192.168.13.1

 

 fw-predictor hash

 

vlan 1 name DEFAULT-VLAN by port

!

vlan 2 name Shaper-Ports by port

 untagged ethe 2/1 to 2/4

 router-interface ve 2

!

vlan 3 by port

 untagged ethe 3/1

 router-interface ve 3

!

aaa authentication web-server default local

enable super-user-password .....

no enable aaa console

hostname ServerIron-1

ip route 192.168.15.0 255.255.255.0 192.168.13.1

ip route 192.168.11.0 255.255.255.0 192.168.12.1

ip route 192.168.10.0 255.255.255.0 192.168.12.1

!

link-keepalive eth 2/1 eth 2/2

link-keepalive eth 2/3 eth 2/4

telnet server

username admin password .....

no snmp-server

snmp-server community ..... ro

snmp-server community ..... rw

!

interface ethernet 3/2

 disable

!

interface ethernet 3/5

 disable

!

interface ve 2

 ip address 192.168.13.2 255.255.255.0

!

interface ve 3

 ip address 192.168.12.2 255.255.255.0

!

end

 

 

ServerIron-2

 

!Current configuration : 1378 bytes

!

ver 10.2.01mTD4

!

module 1 bi-0-port-wsm6-management-module

module 2 bi-jc-16-port-gig-copper-module

module 3 bi-jc-16-port-gig-copper-module

!

global-protocol-vlan

!

trunk switch ethe 2/1 to 2/4

!

server fw-port 2/1

!

!

server force-cache-rehash

!

context default

!

server fw-name 02/01PS1 192.168.13.3

!

server fw-name 02/02PS2 192.168.13.4

!

server fw-name 02/03PS3 192.168.13.5

!

server fw-group 2

 l2-fwall

 fw-name 02/01PS1

 fw-name 02/02PS2

 fw-name 02/03PS3

 

 fwall-info 1 2/1 192.168.13.2 192.168.13.2

 fwall-info 2 2/2 192.168.13.2 192.168.13.2

 fwall-info 3 2/3 192.168.13.2 192.168.13.2

 

 fw-predictor hash

 

vlan 1 name DEFAULT-VLAN by port

!

vlan 2 name BACKEND by port

 untagged ethe 2/1 to 2/4

 router-interface ve 2

!

vlan 3 by port

 untagged ethe 2/9 to 2/10 ethe 3/1

 router-interface ve 3

!

aaa authentication web-server default local

enable super-user-password .....

no enable aaa console

hostname ServerIron-2

ip route 0.0.0.0 0.0.0.0 192.168.13.2

!

link-keepalive eth 2/1 eth 2/2

link-keepalive eth 2/3 eth 2/4

telnet server

username admin password .....

no snmp-server

snmp-server community ..... rw

snmp-server community ..... rw

web-management page-size 1

!

interface ve 2

 ip address 192.168.13.1 255.255.255.0

!

interface ve 3

 ip address 192.168.15.1 255.255.255.0

!

end

 

Cause
Resolution
Workaround
Additional Information
Bug Number
InQuira Doc IdFAQ717
Attachment

Article Feedback

Did this Article solve your issue?
Additional Comments:
 
Previous MonthNext Month
SunMonTueWedThuFriSat