Static routes disappear after a rollback

Solution

Overview

Upgrading to the latest version, and rolling back, deletes the static routes you configured in your Director appliance.

Cause
Resolution

To duplicate this issue, follow these steps:

  • Ensure your SGME version is 5.5.2.4.
  • Configure a static route.
  • Upgrade to 5.5.2.4 as per the below CLI example.

************************************************************************************

director (config) # upgrade-package install Director_5.5.2.4_75869_510.tgz
Warning: The install process will install the upgrade and reboot the director.
Proceed with installation? (yes or no)yes

Configuration File config-5.4.2.5-2011.12.28-071616 is created
Please wait while the install process is in progress. 

************************************************************************************

  • Using the show routes command, ensure the routes are still there.
  • Run the upgrade-package rollback command.

Result: The route disapears after a rollback. The reason for this behavior is that the Rollback command only moves the software back to the previous version. It does NOT rollback the configuration. After rolling back, you must restore the Director archive.

Fix: Use the "configuration switch to" command to restore the archive which Director creates automatically during an upgrade.

Links to other articles:

For details on a problem with static routes, and overlay files, see 000014455

For more details on other command line commands ( CLI), see 000014637

Workaround
Additional Information
Bug Number
InQuira Doc IdKB4829
Attachment

Article Feedback

Did this Article solve your issue?
Additional Comments:
 
Previous MonthNext Month
SunMonTueWedThuFriSat