Value of ‘tcp-keepalive-timeout’ is not included in the Sysinfo and Configuration Archive

Solution

Overview

When the value for ‘tcp-keepalive-timeout’ is changed from its default value of 7200 seconds, the new value is not included in the Sysinfo and Configuration Archive. This prevents this configuration from being accurately replicated to another ProxySG.

Cause
Resolution

This issue has been addressed in

- SG 5.4.7.1 and newer SG 5.4.x versions

- SG 5.5.11.1 and newer SG 5.5.x versions

- SG 6.1.5.1 and newer SG 6.1.x versions

 

This issue is not present in SG 6.2 and newer SG 6.x versions

 

Workaround

1. Manually obtain the TCP-Keepalive-Timeout value through the following command :

SG200#show xml-config config:Ip:tcp_keepalive_idle

<?xml version="1.0" encoding="UTF-8"?>
<registry>
<n k='tcp_keepalive_idle' t='unsigned32' v='0XE10'/>                   <<<<< Take note of the value for 'v'
<properties>
  <heap_info>
    Registry new() called at priorities: .
  </heap_info>
  <file_format>1</file_format>
  <revision>6042</revision>
  <count>1</count>
  <hash_count>0</hash_count>
  <CK_System_version_string>Version: SGOS 5.5.8.2</CK_System_version_string>
  <CK_System_release_id_string>Release id: 78777</CK_System_release_id_string>
  <date_and_time_utc>2012-01-16 07:34:15+00:00UTC</date_and_time_utc>
  <date_and_time_local>2012-01-16 15:34:15+08:00SGT</date_and_time_local>
</properties>
</registry>


2. Manually convert the 'v' value from Hexadecimal to Decimal. For example :

<n k='tcp_keepalive_idle' t='unsigned32' v='0XE10'/>                 <<<<< 0xE10 is 3600

3. Manually configure the value in the destination proxy :

SG200#config term

SG200#(config)tcp-ip tcp-keepalive-timeout 3600

SG200#(config)exit

SG200#disable

Workaround
Additional Information
Bug Number
InQuira Doc IdKB4865
Attachment

Article Feedback

Did this Article solve your issue?
Additional Comments:
 
Previous MonthNext Month
SunMonTueWedThuFriSat