Why does the "Error: (code 99) An internal error occurred message" display on the Blue Coat Director?


<< Back to Knowledge Search

Solution

Overview

Some Command Line interface ( CLI) commands fail when used on the Director, and the UI displays the error "Error:  (code 99) An internal error occurred."

This message is also logged in the var/log/messages file on the Director.

Internal Error - device communication interrupted policy reset % Internal Error - device communication interrupted ;;END MANUAL SETTINGS % Internal Error - device communication interrupted

  1.  We see this message on the target SG.

+-------------------------------------------
| Output for device "10.9.31.108"
+-------------------------------------------
;;BEGIN MANUAL SETTINGS
Error:  Internal Error - device communication interrupted
policy reset
Error:  Internal Error - device communication interrupted
;;END MANUAL SETTINGS
Error:  Internal Error - device communication interrupted
Overlay execution complete for device "10.9.31.108"

Cause
Resolution

These errors manifest on these versions:

Version of Director: SG-ME 5.5.1.1 #50387 2010.09.

SG version and Model: SG 210 SGOS 5.5.3.1

Steps to duplicate this error:

  1. Open a Web browser and access the Director Management Console.  You must enter valid credentials for access.
  2. Click the Configure tab.
  3. Choose Overlays from Configuration Library drop down on the right.
  4. Click New then choose New Overlay.
  5. Name the overlay.
  6. From the Add To Overlay menu, choose Using CLI.
  7. Cut and paste the following text in to the new window that displays:

    proxy-services
    delete Echo
    import Echo
    exit
  8. Click OK to close the open dialogs and save your changes.
  9. Highlight a test ProxySG such as  <TEST-SG>, and execute the overlay you just created.
    1. Click Execute.
    2. Click Yes when prompted to execute overlay <name you chose in step 5> on device ‘<TEST-SG>.

Workaround: While Bluecoat works on a solution to this problem, please execute these commands directly on the SSH interface of the ProxySG.  If you see this problem, please log a Service Request and quote this article. 

NOTE1:  One reason for this symptom is the "policy reset" CLI command is expecting user input of a 'yes/no'. which Director does not provide.

NOTE2: For a similiar symptom, using cipher commands, see 000008723

NOTE3: For details on what we will ask for,  when you log a service request, see 000015422

Workaround
Additional Information
Bug Number
InQuira Doc IdKB4253
Attachment

Article Feedback

Hide Properties
First Published      10/01/2014
Last Modified      10/01/2014
Last Published      10/01/2014
Article Audience
Product      Director 510
Topic      Configuration / WUI / CLI, Director Jobs
Article Number      000016302
Summary     
Was this helpful?
Comments:
 
Previous MonthNext Month
SunMonTueWedThuFriSat